Tutorial One: Basic

Step-By-Step Instructions To Create A Simple Single Level Roof
# Table of Contents

- **Overview** .................................................................................................................... 1
- **Step 1: Draw the Outline of the Roof** ........................................................................ 2
- **Step 2: Construct the Hips, Valleys and Ridges** ....................................................... 4
- **Step 3: Input the Roofing Materials** .......................................................................... 9
- **Step 4: Three Dimensional (3D) View** ..................................................................... 13
- **Step 5: Stock View** .................................................................................................. 14
- **Step 6: General Project Input** .................................................................................. 15
Overview

The user will be prompted step by step through Exact-Roofing to draw and quote the following roof plan drawing.
Step 1: Draw the Outline of the Roof

Begin by drawing the outline of the roof. Enter from the pull down menu Plan->Construct->Outline as shown below:

In the drawing window move the crosshair horizontally to the right to approximately 8300 and click the left mouse button don’t worry if you are not accurate. A message window will immediately appear (Figure 2) to confirm the dimension and angle of the line. It may be necessary to change the dimension in the highlighted box to 8300 and to make sure the line is horizontal change the Line Direction to Horizontal. Change the Line Command to Draw. Then click on the Next button.
Move the crosshair vertically 1000 and click the left mouse button. Again change the numbers in the message window if they are not correct and click on the Next button.

Now trace around the external perimeter of the entire plan entering the dimensions shown in Figure 1, ignoring hips, ridges and valleys at this stage. On reaching the end in the message window click the Finish button. (Note that a right mouse button click will allow an Undo).

A new window will appear asking if you wish to add a hole. There are no holes in this sample drawing so click Next button. Your drawing should now look like Figure 3.
Step 2: Construct the Hips, Valleys and Ridges

There are two methods, which can be used construct the Hips, Valleys and Ridges.

The first is to use the Roof Skeleton command. This is an automatic roof drawing tool that assumes all exterior edges are eaves. While this can never predict exactly the roof shape, it usually provides an excellent starting point from which the user can modify the roof. The Roof Skeleton command is described in Method One.

The second method is a manual drawing method which is used if the roof shape is non-standard and the Roof Skeleton produces a roof shape quite different from that desired to be drawn. The manual drawing method is described in Method Two.
**Step 2: Method One**

Construct the skeleton by entering **Plan->Construct->Roof Skeleton** or use the keyboard shortcut “K” on the keyboard. Move the mouse to any line on the perimeter of the previously drawn outline and click the left mouse button. The roof skeleton will be drawn as shown below (with lines shown in the freehand drawn circle, being incorrect for this particular roof).

![Figure 4](image)

Now remove the unwanted Hip, Valley and Ridge lines by entering **Plan->Construct->Remove/Erase Line** or use the keyboard shortcut “E” on the keyboard. Move the crosshair to any of the lines and click the left mouse button. Similarly remove the other incorrect lines. Note that the letter “R” on the keyboard or the “Space Bar” can be used to repeat the last command.

(Note as an aside, that while not required for this roof, a hip can be changed to a barge with the command **Plan->Construct->Hip to Barge** and clicking the left mouse button over the intersection point of the two hips and ridge).

The drawing should now look similar to Figure 5.
Step 2: Method Two

Construct the Hip by entering Plan->Construct->Hip or use the keyboard shortcut “H” on the keyboard. Move the mouse represented by a cross (crosshair) to the line marked “A” in Figure 5 and click the left mouse button. The hip will be drawn automatically. Press the letter “R” on the keyboard to repeat the last command. Move the mouse crosshair to the line marked “C” in Figure 5 and click the left mouse button.

Figure 5

Now construct the Ridges and Valleys. Enter Plan->Construct->Bisector. Move the crosshair to the line marked “A” and click the left mouse button. A bisecting construction line will be drawn automatically. Press the letter “R” on the keyboard to repeat the last command.

Now construct the bisector at “B” there is no need to re-enter the command, as the program will remember the last command entered when we use the repeat the last command. Move the crosshair to the point marked “B” and click the left mouse button. Press the letter “R” on the keyboard to repeat the last command. A bisector will be drawn automatically. (Note that the crosshair must be close to the corner so the program can identify the user wants to bisect the corner rather than a line).

Similarly move the crosshair to the line marked “C” and click the left mouse button. Press the letter “R” on the keyboard to repeat the last command.

Now move the crosshair to the corner marked “D” and click the left mouse button. We have finished with bisectors so there is no need to repeat the last command again.

The drawing should now look similar to Figure 6.
Figure 6

We are now able to draw the hips, ridges and valley lines.

Enter **Plan->Construct->Point of Intersection to Point**.

Using the letter shown in Figure 6:
Move the crosshair to “E” and click the left mouse button, then move the crosshair to “F” and click the left mouse button. Press the letter “I” on the keyboard to repeat the point-to-point command.

Move the crosshair to “F” and click the left mouse button.
Move the crosshair to “G” and click the left mouse button.
Press the letter “I” on the keyboard to repeat the point-to-point command.

Move the crosshair to “G” and click the left mouse button.
Move the crosshair to “C” and click the left mouse button.
Press the letter “I” on the keyboard to repeat the point-to-point command.

Move the crosshair to “G” and click the left mouse button.
Move the crosshair to “D” and click the left mouse button.
Press the letter “I” on the keyboard to repeat the point-to-point command.

Move the crosshair to “F” and click the left mouse button.
Move the crosshair to “B” and click the left mouse button.
Press the letter “I” on the keyboard to repeat the point-to-point command.

Now remove all the bisectors by entering **Plan->Construct->Remove All Bisectors** or alternating use the shortcut key “M” on the keyboard.

The plan should now look as follows:
Step 3: Input the Roofing Materials

The drawing is at the stage when the roofing products can be added. To input the roofing materials enter **Plan->New->Roof Area** on the main window’s menu (NB: the shortcut key is the letter “N” on the keyboard) as shown in Figure 8.

Move the crosshair to “S” on the centre of left hand vertical line at and click the left mouse button. The hip side of the roof will be highlighted in blue a new window will open.

This window shown in Figure 9 will permit the entry of the geometry of the roof note that the eave height (*height above grade*) is 2400 and the pitch is 30 degrees.
Select the Next button choose the roofing material, underlay and timber required. Press the letter “R” on the keyboard to repeat the last command.

Now move the crosshair to “T” and click the left mouse button. Note that this roof section has a portion that falls past the standard eave height but the program will take care of this automatically. We will need to manually specify where the walls lie though.

The Define Roof Outline window will appear. Change the Style to Shed, change the Height above Grade to 2400, change the Walls to Define, and click the Next button.

As Define Walls was selected you can now define the individual offsets for each wall. Walls 1, 2, 3, 4 and 5 should be offset 400 whereas walls 6, 7, and 8 have no offset. Hence move the mouse pointer down to Wall No 6 and click on the Set No Offset button. The highlighted box will automatically move down to Wall No. 7 so click on the Set No Offset button again, until Wall No. 8 is reached and set to no offset. The drawing should now look similar to that in Figure 10.

![Figure 10](image)

Click the OK Button and the select the appropriate roof products. The program will apply the products already selected from the first roof area, if they are applicable to this area. Products can be edited later.

Press the letter “R” on the keyboard to repeat the last command or “N” for Plan->New->Roof Area

Similarly move around the eaves “U”, “V”, “W” and “X” selecting each part of the roof in turn, remember to press “N”, “R” to reselect the command or reselect the command that is needed from the main window’s menu or popup menu that comes up when you click on the drawing window.

The drawing should now look similar to Figure 11.
Figure 11

You have now finished drawing the roof.

Note that the left hand window (below the logo) which was previously blank, now has a summary of the items. If you click on the *Click to Dock treatment display* button under the logo, the treatment window will appear. If the user then clicks on the ridge in the list of summary items in the bottom left hand window, the material used will be displayed. If you double click on the ridge item or select the (+) to expand the tree list, it shows two ridges exist. If you select one of these items the appropriate ridge will be highlighted in blue in the drawing as in Figure 12 below.
Note that double clicking on any individual sub item will allow the previously selected material to be edited, so it is possible to have one ridge product on one ridge and a different on another.
Step 4: Three Dimensional (3D) View

To show a 3D View of the design use the pull down menu on the main window View->3D or simply click on the 3D tab at the bottom left of the window.

The 3D diagram can be rotated (by default 20 degrees at a time) and the user can verify the house was drawn correctly.

Using the pull down menu Tools->Layers/Graphics. The user can turn on/off layers to enable viewing of the timber and walls.
Step 5: Stock View

Select the pull down menu View->Stock or alternatively click on the Stock Tab at the bottom left of the main window. The drawing should be similar to that shown in the Figure below. This drawing shows the individual tiles and is of little value for normal tile drawings. However if long run was selected an optimised layout of the roofing will be displayed.
Step 6: General Project Input

Select the pull down menu **View->Quote** or alternatively click on the **Quote** Tab at the bottom left of the main window. The drawing should be similar to that shown below.

The General Project information should now be input via the buttons of the left hand side of the main window, namely:

*Project Information->Name, Address…*

*Miscellaneous Items*

*Discount/Markup*

*Notes On Summary*
Select the Project Information->Name, Address... button. A window will appear as shown in Figure 13. Enter the information pertaining to the job. This information will appear on the printouts. Note the options in the Summary Footer may change depending on the setup options selected in configuration file. The SAP info button allows entry of more information for exporting to an enterprise management system such as SAP.

![Project Information Window](image)

Figure 13

Select the Miscellaneous Items button. A window will appear as shown in Figure 14. Enter the miscellaneous items pertaining to the job. The filters at the top can filter the items visible in the product file to assist selection. Note the first colour filter is Colour TAB and None. This filter is hard coded and selects all products with a colour of “Colour to be advised” and those with no colour; effectively eliminating all products with colour from the view.
### Miscellaneous Items

<table>
<thead>
<tr>
<th>Description</th>
<th>Item Qty</th>
<th>Unit</th>
<th>Base Price</th>
<th>markup Price</th>
<th>Total of Price</th>
<th>Item Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base End Fascis Colour to be Advised</td>
<td>1</td>
<td>Each</td>
<td>$1.80</td>
<td>$1.80</td>
<td>$1.80</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Base End Fascs Textured Colour to be Advised</td>
<td>1</td>
<td>Each</td>
<td>$2.00</td>
<td>$2.00</td>
<td>$2.00</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Angle Trim End Fascis Colour to be Advised</td>
<td>1</td>
<td>Each</td>
<td>$2.00</td>
<td>$2.00</td>
<td>$2.00</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Angle Trim End Textured Colour to be Advised</td>
<td>1</td>
<td>Each</td>
<td>$2.00</td>
<td>$2.00</td>
<td>$2.00</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Colliers, Nails and Washers</td>
<td>1</td>
<td>Each</td>
<td>$0.25</td>
<td>$0.25</td>
<td>$0.25</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Touch Up Kit Fascis Colour to be Advised</td>
<td>1</td>
<td>Each</td>
<td>$0.80</td>
<td>$0.80</td>
<td>$0.80</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Repair Kit Textured Colour to be Advised</td>
<td>1</td>
<td>Each</td>
<td>$0.85</td>
<td>$0.85</td>
<td>$0.85</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Site Signs - Large</td>
<td>1</td>
<td>Each</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Site Signs - Docel</td>
<td>1</td>
<td>Each</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Site Danger Signs</td>
<td>1</td>
<td>Each</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
<td>MiscMaterial 0</td>
</tr>
<tr>
<td>Medium 3 Screen Work Allowance</td>
<td>1</td>
<td>Each</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
<td>MiscMaterial 0</td>
</tr>
</tbody>
</table>

**Total Roof Area = 171.35 sq.m**

**Total Tile Count = 410**

---

Figure 14
**Discount/Markup**

Select the *Discount/Markup* button and enter the various discounts or markups.

![Discount/Markup interface](image-url)
Notes on Summary

Select the Notes On Summary button and a window similar to that shown below will appear. Use this to add notes to the summary quote.

The quote is now complete.

The quote and other printouts may be printed by checking the check box beside the name of the actual printout and selecting the Print button.