
Tutorial Two: Advanced

Step-By-Step Instructions To Create A Two Storied Roof
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Overview
This tutorial gives the step-by-step instructions to draw and quote for the following roof plan
shown below in Figure 1 and Figure 2.

Figure 1

Figure 2
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Step 1: Draw The Upper Story
Begin by drawing the outline of the upper storied roof only. Enter from the pull down menu Plan-
>Construct->Outline and draw a 19’ 8” x 16’ 4-1/2” box as shown below.

Note the letters A, B, C etc… on the following plans are not part of the drawing; they are for
describing actions the user should take. Also note that the drawings may not appear the same
relative size to the page as seen by the user. That is because the drawings in the examples
below may be zoomed in or out. The user may zoom in and out using the magnifying glass icon
with the plus sign to zoom in, and the negative sign to zoom out.

Figure 3

Zoom In/Out
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There are three methods which can be used to construct the upper story:
1) The upper story can be constructed using the Hip commands and then joining the apex

of the two hips to form a ridge similar to how the roof was constructed in the first tutorial.
2) Or constructed using the Roof Skeleton Command from the pull down menu

Plan->Construct->Roof Skeleton.
3) Or if the roof is a simple symmetrical hip roof then the roof can be constructed in one

step as follows.

Enter from the pull down menu Plan->New->Roof Area or alternatively type the letter “N” for
New Roof Area. Move the mouse represented by a cross (crosshair) to the line marked “A” in
Figure 3 and click the left mouse button. The screen shown in Figure 4 will appear. In the Define
Roof Outline window change the Style to Hip, change the height above grade to 18’, and the
walls to All Edges, and click the Next button.

Figure 4

Now specify the products for Ridge, Hip and Eave from the menus and the original outline will
be adjusted to the drawing shown in Figure 5.

Change

Change

Change
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Figure 5
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Step 2: Draw The Lower Story
The upper story roof outline and walls (drawn in Step 1) are required to draw the lower story.
however the roofing material and roofing timber shown in the adjusted top story (Figure 5) will
throw confusion into the drawing. It is possible to hide roofing material so that only the outline of
the roof can be seen. It is not necessary, but it may also be desirable, to draw the lower story
outline in a different layer from the upper story.

Select from the pull down menu Tools->Layers/Graphics, a window will appear as shown in
Figure 6. Turn off the Roofing and Timber layers by clicking on the icons. Note that the icon is a
toggle, meaning the layer can be clicked on or off at any time. Now click on the Drawing Layer
Options button to create a new layer as shown in Figure 6. All lines from now on will be drawn in
the second layer. A pencil image is shown in the Outline layer that is active next to the eye
toggle.

Note the window can be moved around the page by clicking on the shaded area at the top of
the window, and while holding the left button down move the pointer. The layer window can be
moved to any position or de-activated by clicking in the “x” box at the top right hand corner. If it
is de-activated it can be re-activated at any time from the pull down menu.

Figure 6

Prior to drawing the lower story outline it may be more convenient to zoom out using the
magnifying glass with the negative sign. Select the pull down menu
Plan->Construct->Outline and move to the top left corner of the previous upper story. Now
move the pointer in the general direction of the top left hand corner of the lower story and click
the left mouse button.

1) Click Here

2) Click Here

3) Click Here
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The direct distance and angle to the corner is not
known but we do know the horizontal and vertical
offsets from our drawing guide. By changing the
Horizontal offset to –11’ and the Vertical offset to 5’
1-1/2”; as shown in Figure 7 below the direct
distance and angle will be automatically calculated.
Now change the Line Command from a Draw to a
Move, as you wish to “move” to the corner rather
than “draw” a line to the corner. Click on the next
button and you are now in the correct starting point
to draw the outline for the lower story.

Figure 7

Now construct the lower story outline and create a drawing similar to that shown in Figure 8
below.

Change
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Figure 8

From the pull down menu Plan->Construct->Bisector construct the bisectors at points A, B, C,
D, E and F. Select “R” on the keyboard to repeat the last command after each bisector. The
drawing should look similar to Figure 9 below.

Figure 9

Now using Plan->Construct->Point of Intersection to Point join up the points of the ridges,
hips and valleys. Again remember to select the command each time or use “R” on the keyboard
to the repeat the last command. The drawing should be as shown in Figure 10. Now remove the
bisectors with the Plan-> Construct->Remove All Bisectors pull down menu or alternatively
user the shortcut “M”. Note there is one hip missing, which will be constructed now.
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Figure 10

The best method of drawing the missing hip is to draw a construction line (a bisector is just one
form of a construction line) at 45 degrees from point “A”; then use the Point of Intersection to
Point command to draw the hip.

Select the pull down menu Plan->Construct->Polyline and point to the pointed marked “A” in
Figure 10. Now move the pointer off at 45 degrees past the wall, as shown in Figure 11 and
click the left mouse button.

Figure 11

Now a window will appear as shown in Figure 12. Change the Line Command to “Construct”
and click the Next button. Now, as there are no more polyline commands to do, click the “right”
mouse button and select exit. You will now have the required construction line.
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Figure 12

Now using Plan->Construct-> Point of Intersection to Point or keyboard shortcut “I” draw a
line from point “A” in Figure 10 to the wall of the upper story to draw the last hip. Now remove
the bisectors with the Plan->Construct->Remove All Bisectors from the pull down menu or
keyboard shortcut “M”.

The drawing should now appear as in Figure 13 and the line drawing part is complete.

Figure 13

Change
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Step 3: Input The Lower Story Roofing Material

Enter from the pull down menu Plan->New->Roof Area or alternatively type the letter “N” for
New Roof Area. Move the crosshair to the line marked “A” in Figure 13 and click the left mouse
button. The screen shown in Figure 4 will appear. In more complex roofs there are several
possible solutions for any one roof, so there are several “Search Methods” available to the user.
Clearly the first attempt by the program failed to arrive at the desired result, so click on the back
button and a window will appear as show in Figure 15.

Figure 14

Click on the Yes button to try a different search method.

Figure 15

The Define Roof Outline window will appear. Change the Style to Shed, change the Height
above Grade to 8’, change the Walls to Define, and click the Next button.
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Figure 16
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As Define Walls was selected you can now define the individual offsets for each wall. Walls 1
and 2 should be offset 1’-6” whereas walls 3 to 7 have no offset. Hence move the mouse pointer
down to Wall No 3 to highlight the row and click on the Set No Offset button. The highlighted
box will automatically move down to Wall No. 4 so click on the Set No Offset button again, until
Wall No. 7 is reached. The drawing should now look similar to that in Figure 18.

Figure 17

Figure 18

Note that the Set No Offset button and the Set Std Offset button are convenient ways to set the
wall offsets. Individual offsets can be entered into the grid if required.

Now click on the OK button to proceed to defining the products.
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You will be requested to enter the products for the Barge; and as the program will detect that
the roof meets the wall of the upper story, the program will also request products for the Side
Ledge and Upper Ledge.

Once the menus are completed the drawing should look similar to that shown in Figure 19
below.

Figure 19

Select the pull down menu Plan->New->Roof Area or alternatively type the letter “N” for New
Roof Area. Move the crosshair to the line marked “B” in Figure 13 and click the left mouse
button. The Walls radio button should remain on from Define. This time set the walls numbers 2
and 3 to no offset.

Now select the pull down menu Plan->New->Roof or use the keyboard shortcut “N” for New
Roof Area or “R” for repeat last command. Move the crosshair to the line marked “C” in Figure
13 and click the left mouse button. The first search method will fail, and after clicking on the
Back button so will the remainder of search methods. (The search may have been successful
depending on exactly how the outline was drawn, however the following method of entering a
roof is valid in all circumstances, but it’s main use if for manual entry if the search methods fail).

Select the pull down menu Plan->New->Roof Trace… as shown in the Figure 20.

Now trace around the perimeter of the roof section as shown in Figure 21, and when the tracing
is completed click on the Finish button.
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Figure 20

Figure 21

Figure 22

Change if necessary

Change
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By default the Eave Line will be the first line traced. If the Eave Line is not adjacent to the actual
eave, then click on the button Next Edge to move the eave line around the perimeter.

Change the Walls from Define to Eave Only. The Eave Only option sets the standard offset for
the eave, and no offset for the other walls and is faster than going through the Define option.
When complete click on the Next button. The program will automatically detect a valley will be
prompted to enter products for the valley.

Select the pull down menu Plan->New->Roof Area or
alternatively use the keyboard shortcut “N” or “R”. Move
the crosshair to the line marked “D” in Figure 13 and
click the left mouse button.
Do the same for the line marked “E”.

The drawing should now be similar to that shown in
Figure 24 below. The drawing process is complete.

Figure 24
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Step 4: 3D View
Select the pull down menu View->3D or alternatively click on the 3D Tab at the bottom left of
the main window. The drawing should be similar to that shown in Figure 25 below. Use the
button to rotate the house to check that no input errors have been made. If there are errors,
return to the Plan view, and click on the Tree diagram to amend the drawing.

The 3D View may be printed as it is often useful for marketing purposes.

Figure 25
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Step 5: Stock View
Select the pull down menu View->Stock or alternatively click on the Stock Tab at the bottom left
of the main window. The drawing should be similar to that shown in Figure 26 below. This
drawing shows the individual tiles and is of little value for normal tile drawings. However if long
run was selected an optimized layout of the roofing will be displayed.

Figure 26
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Step 6: General Project Input
Select the pull down menu View->Quote or alternatively click on the Quote Tab at the bottom
left of the main window. The drawing should be similar to that shown in Figure 27 below.

Figure 27

The General Project information should now be input via the buttons of the left hand side of the
main window, namely:
Project Information->Name, Address…
Miscellaneous Items
Discount/Markup
Notes On Summary
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Project Information->Name, Address…

Select the Project Information->Name, Address… button. A window will appear as shown in
Figure 28. Enter the information pertaining to the job. This information will appear on the
printouts. Note the options in the Summary Footer may change depending on the setup options
selected in configuration file. The SAP info button allows entry of more information for exporting
to an enterprise management system such as SAP.

Figure 28

Select the Miscellaneous Items button. A window will appear as shown in Figure 28. Enter the
miscellaneous items pertaining to the job.  The filters at the top can filter the items visible in the
product file to assist selection. Note the first colour filter is Colour TAB and None. This filter is
hard coded and selects all products with a colour of “Colour to be advised” and those with no
colour; effectively eliminating all products with colour from the view.
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Miscellaneous Items

Figure 29
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Discount/Markup

Select the Discount/Markup button and enter the various discounts or markups.

Figure 30
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Notes on Summary

Select the Notes On Summary button and a window similar to that shown in Figure 31 below will
appear. Use this to add notes to the summary quote.

Figure 31

The quote is now complete.

The quote and other printouts may be printed by checking the check box beside the name of the
actual printout and selecting the Print button.


