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Step-By-Step Instructions To Create A Long Run/Standing Seam Roof  Quote
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Overview

The user will be prompted step by step to draw, quote and create a construction layout plan for
the following long run/standing seam roof.
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Step 1 : Draw the Outline of the Roof

Begin by drawing the outline of the roof. Enter from the pull down menu
Plan->Construct->Outline as shown below in Figure 1-1.

Figure 1-1

Construct the skeleton by entering Plan->Construct->Roof Skeleton or use the keyboard
shortcut “K” on the keyboard or the Roof Skeleton Icon. The drawing should now look like
Figure 1-2.

           
Figure 1-2
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Input the roofing materials with Plan->New->Roof Area or using the shortcut key “N” on the
keyboard or the New Roof Area Icon. Start with the eave line marked “A” in Figure 1-3. In
Define Roof Outline retain the default settings and click on the Next -> button. Choose a Long
Run/Standing Seam product and preferably the DD Brand, Corrugate 0.55 ZR8, Color TBA
which is in the PRODUCT.CSV database supplied with the software. (A different product may
have a different width and so using this product will ensure all the measurements match for the
remainder of this tutorial).  Accept the defaults for all the other materials as they are irrelevant
as far as this tutorial is concerned.

Similarly input the roofing materials for the other roof areas moving round from B to C,D,E and
F.

Figure 1-3

The roof should now look like Figure 1-4.
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Figure 1-4
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Step 2 : Adjust Source Sheet Lengths

Click on the Stock Tab or use the pull-down menu View->Stock to view the optimized layout of
the sheets. The Roof Sheets are cut from “Source Sheets”. The Source Sheet lengths are
calculated by the program based on a search of the roof to find the most optimal lengths. The
user has the facility to decide if some or all of the Source Sheets are used. To change the
available source sheets use the pull-down menu Stock->Edit Source Sheet Lengths. The
window will appear as in Figure 2-1.

Figure 2-1

For a very conservative quote, and for the purpose of this tutorial, ensure the shorter sheet
length of 4.092m is checked off as in Figure 2-1. This means the entire quote is derived from a
single length 8.711m of roofing and as such would be very conservative. Click Ok, the program
will take a few seconds to re-optimize the sheets, and then click on the Quote Tab or select the
pull-down menu View->Quote.

Now click on the Bill Of Materials printout and it can be seen that the program calculates that
453m of Roofing (52 Sheets @ 8.711m) are required.

Now click on the Stock Tab again or click on the View->Stock pull-down menu. Now click on
the pull-down menu Stock->Edit Source Sheet Lengths again and this time check both the
8.711m and 4.092m sheets on as shown in Figure 2-2.
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Figure 2-2

Click Ok and then return to the Quote View by clicking on the Quote Tab or selecting the pull-
down menu View->Quote.

Again click on the Bill Of Materials printout and it can be seen that the program now calculates
that 452m of Roofing (21 Sheets @ 4.092m) and (42 Sheets @ 8.711m) are required.

This figure will still be conservative because the layout has been designed by the computer and
a computer is no match for an experienced roofer. However experience has shown that the
452m above will generally be around 3 to 5% over the actual amount of roofing required. Hence
this is good enough for a quote but can be improved further by the user manually altering the
layout.

It is up to the user to decide whether the above figure is good enough for a quote and whether
further optimization is to be done later on successfully obtaining an order; or if further
optimization is required now.

The remainder of the tutorial deals with the manual optimization of the layout of the sheets on
the roof.

Click on the Plan Tab or use the pull-down menu View->Plan to return to the plan view.
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Step 3 : Adjust Roofing Start Points

The manual adjusting of the roof sheets is done in the Plan view. The final layout may depend
on many factors such as wind direction and whether it is important to hide the seams from a
certain direction.

Hence two experienced roofers may come up with a completely different layout. However there
are several basic principles which the remainder of this tutorial will show, but in doing so several
arbitrary decisions will be made. As the person making the decisions is interested in getting the
most optimum layout and thereby “maximizing” profitability, for the purpose of this tutorial the
experienced roofer making the decisions will be referred to as “Max”.

For the purpose of this tutorial click on the pull-down menu Stock->Show Sheet Blocks. This
shows the sheet blocking as devised by the program. Unless the roof is very straight forward
this will require some manual changes to come up with the best result. Click on the pull-down
menu Stock->Show Sheet Blocks again to turn the sheet blocking off.

Now we will start the manual adjustments.

The starting point for laying out the sheets for Roof Area 1 was decided by the program to be
the left hand corner. However this means the sheet  numbered 1:14 (and marked with the letter
A) in Figure 3-1 requires a double cut. Max wishes to avoid the double cut on sheet 1:14 and so
would like to adjust the Roofing Start Point so the double cut is avoided.

Figure 3-1
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Click on Roof Area 1 in the tree diagram on the left hand side of the screen. Click on the menu
item Edit Roofing Start Point as in Figure 3-2.

Figure 3-2

The pen will be placed at the existing Roofing Start Point of Roof Area 1. Place the crosshair at
the point marked B in Figure 3-3 and click the left mouse button. Note the Roofing Start Point
can be set to this point but in doing so the program will assume that it is required that the roof
sheets be split on the horizontal AND on the vertical at this point. Hence it is always best to set
the Roofing Start Point on the eave. Click the Next-> button.

Now move the crosshair to the eave at the point marked C in Figure 3-4 and click the left mouse
button. Click on the Finish button and the new origin will be relocated to the point C. The
drawing should now look as in Figure 3-5. Note the changed Sheet Alignment in Roof Area 1.
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Figure 3-3

Figure 3-4
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Figure 3-5

Max now decides that the off-cuts from the sheets on the right hand side of Roof Area 1 should
be placed as the upper part of Roof Area 2. The first off-cut will be from sheet 1:22 (marked A)
and this off-cut should be sheet 2:18 as show in Figure 3-6.

Figure 3-6
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However sheet 2:18 is clearly smaller than the off-cut from 1:22 so the Roofing Start Point of
Roof Area 2 needs to be adjusted so the off-cut from 1:22 fits perfectly into the position of 2:18.

To do this firstly inspect the dimensions of sheet 1:22 by clicking on the pull-down menu
Plan->Dimensions->Roof Sheet  or by pressing the shortcut function key F5. Move the
crosshair to point marked A in Figure 3-6 and click the left mouse button. The dimensioned
sheet should appear as show in Figure 3-7.

Figure 3-7
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It can be seen the dimension of the off-cut is 788mm. Hence the Roofing Start Point of Roof
Area 2 should be 788mm from the top.

Click on Roof Area 2 in the tree diagram on the left hand side of the screen. Click on the menu
item Edit Roofing Start Point as in Figure 3-8.

Figure 3-8

The pen will be placed at the existing Patter Origin of Roof Area 2. Place the crosshair at the
top right hand corner of the roof and click the left mouse button. Now move the crosshair
vertically down and click the left mouse button. Change the dimension to 788mm as shown in
Figure 3-9 and click on the Finish button. The new origin will be relocated to this point and the
drawing should look as in Figure 3-10.
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Figure 3-9

Figure 3-10
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Now similarly the smaller off-cut from piece 2:10 marked A in Figure 3-11 should be placed at
position B. Even though this off-cut is very small and somewhat trivial, placing this off-cut at B
will make the adjacent sheets, 2:9, 2:8 and so on match perfectly with the sheets on Roof Area
3. To establish the correct dimension of piece 2:10 (marked A ) in Figure 3-11 click on the pull-
down menu Plan->Dimensions->Roof Sheet  or press the shortcut function key F5. Now move
the crosshair to point marked A in Figure 3-11 and click the left mouse button.

Figure 3-11

The dimensioned sheet should appear as show in Figure 3-12.
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Figure 3-12

It can be seen the dimension of the off-cut is 52mm. Hence the Roofing Start Point of Roof Area
3 should be 52mm from the top right hand side.

Click on Roof Area 3 in the tree diagram on the left hand side of the screen. Click on the menu
item Edit Roofing Start Point (similar to that shown as in Figure 3-8).
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Now move the crosshair in the direction of the point marked C in Figure 3-11 and click the left
mouse button. Enter 52 as the distance, click Draw and Finish. Roof Area 3 will now be
redrawn. As the piece is a very small piece to see the change it may be necessary to zoom in
around the point marked B on Figure 3-11.

Roof Area 5 could be similarly aligned however Max knows that valleys are difficult to align and
so wishes to avoid the double cut at the Valley marked A on Figure 3-13. Hence Max elects to
adjust the Roofing Start Point of Roof Area 4 to be at the point marked A on Figure 3-13.

Click on Roof Area 4 in the tree diagram on the left hand side of the screen. Click on the menu
item Edit Roofing Start Point (similar to that shown as in Figure 3-8).

Now move the crosshair in to the point marked A in Figure 3-13 and click the left mouse button.
Click Draw and Finish. Roof Area 4 will now be redrawn.

Figure 3-13

Similarly align Roof Area 5 to avoid the double cut at the Valley. Click on Roof Area 5 in the
tree diagram on the left hand side of the screen. Click on the menu item Edit Roofing Start
Point (similar to that shown as in Figure 3-8).

Now move the crosshair in to the point marked A and click the left mouse button. Click Draw
and Finish. Roof Area 5 will now be redrawn.

The drawing should now look like that shown in Figure 3-14.
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Figure 3-14

Max knows that the sheet 6:1, the uppermost sheet in Roof Area 6, should match with sheet
4:11. It can be seen that the program has already set the Roofing Start Point of Roof Area 6 to
be correct so the Roofing Start Point of Roof Area 6 does not need to be adjusted.
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Step 4 : Adjust Overlaps and Underlaps

As part of the layout procedure the program decides if a Roof Area is Overlapped or
Underlapped. These Overlaps and Underlaps are automatically established by the program,
and in the case of this tutorial, after making many changes it should be checked whether the
Overlaps and Underlaps are correct. Click on the Stock->Show Over/Underlaps and the
drawing will appear as shown in Figure 4-1.

Figure 4-1

Overlaps and Underlaps are shown in Green and Yellow. The program does not state which
color represents the Overlap and which represents the Underlap, that is left up to the user to
decide.

Max decides that Roof Area 2 should be Yellow and Roof Area 3 should be Green. Click on the
pull-down menu Stock->Edit Area Overlap/Underlap and click the left mouse button on any
sheet in Roof Area 2. The window will appear as shown in Figure 4-2.
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Figure 4-2

Click on Yellow as show in Figure 4-2 and click the Ok button.

Similarly for Roof Area 3 Click on the pull-down menu Stock->Edit Area Overlap/Underlap
and click the left mouse button on any sheet in Roof Area 3. The window will appear as shown
in Figure 4-2. This time click on the color Green and click the Ok button.

Click on the pull-down menu Stock->Show Over/Underlaps and the drawing will appear as
shown in Figure 4-3.

Figure 4-3
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Step 5 : Adjust Source Sheets

For the purposes of this tutorial click on the pull-down menu Stock->Show Sheet Blocks and
view present state of the sheet placement.

The Source Sheets now need to be adjusted. The Source Sheets are the sheets lengths that
the roofing is cut from and in this case there are two, an 8.711 metre sheet and a 4.092 metre
sheet. Click on pull-down menu Stock->Edit Source Sheets and the drawing will appear
similar to that shown in Figure 5-1.

Figure 5-1

The sheets drawn in Red are cut from the longer 8.711m source sheets and those drawn in
Green are cut from the shorter 4.092m length source sheets. It can be see the optimization
system can be improved by manually changing  the source sheets. For example all of the
sheets in Roof Area 5 should be cut from the shorter length sheet. Hence click on any Red
sheet in Roof Area 5 and the window as shown in Figure 5-2 will appear.
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Figure 5-2

Click on the smaller sheet length as shown in Figure 5-2 and click the Ok button.

The sheet to be changed will be cross hatched. Now click the left mouse button on all the other
sheets in Roof Area 5  that are currently red and that are required to be changed to Green.
(Note that clicking on sheets that are already Green will not affect the program).  The drawing
should now appear as show in Figure 5-3.

Figure 5-3

Once finished click the Right Mouse Button and click on Apply Source Sheet Sizes.
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The drawing will appear similar to that shown in Figure 5-4.

Figure 5-4

Note that the sheets are optimized automatically and some sheets particularly those in Roof
Area 2 and Roof Area 3 have reverted to red as they should be. Now repeat the process but this
time changing the Green sheets to Red.  Click on Repeat Last or click on
Stock->Edit Source Sheet twice. Now click on one of the Green sheets in Roof Area 6 or Roof
Area 1 that should be changed to Red (marked with letters A to G in Figure 5-5). The window
will appear as shown in Figure 5-2. This time check the box beside the Green 8.711m sheet.
Now click on the remaining sheets marked with letters A to G in Figure 5-5 that should be
changed to Red.
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Figure 5-5

Once finished click the Right Mouse Button and click on Apply Source Sheet Sizes.
The drawing should now appear as shown in Figure 5-6.

Figure 5-6

For the purposes of this tutorial click on Stock->Show Sheet Blocks. It can be seen that the
layout can be still improved.
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Step 6 : Manually Match Sheets

In the optimizer’s attempt to match sheets it did not see that a better match could be found if the
block marked A-B in Figure 6-1 was matched with the blocked marked C-D and the block
marked E-F.

Figure 6-1

The sheet matching part of the optimizer program can be manually overridden. For individual
sheets this can be done by clicking on the pull down menu
Stock->Apply Pieces To Specific Source Sheet. However often sheets are grouped together
so rather than tediously matching several individual sheets, a group or Block of source sheets
can be matched as a whole (provided order is preserved). This is the approach that will be used
in this tutorial and hence click on the pull-down menu Stock->Apply Area Blocks.

Now click the left mouse button on the sheet marked A in Figure 6-1. The window will appear as
in 5-2 which will allow you to override the source sheet size. Check the check box next to the
longer 8.711m sheet and click the Ok button. Now click the left mouse button at the point
marked B. Click the left Mouse Button on the point marked C and then D. Click the left Mouse
Button on E and finally F.

Now click the Right mouse button and click on Apply Blocks.



25

Now click on Stock->Show Sheet Blocks and the drawing will appear as shown in Figure 6-2.
Note there are several options in the Show Sheet Blocks pull-down menu in the case of the
drawing show in Figure 6-2 small pieces are ignored.

It can be seen the that sheets will now be optimized in their most efficient manner. Use the pull-
down menu File->Print Display to print a copy for construction.

Now return to the Quote View by clicking on the Quote Tab or selecting the pull-down menu
View->Quote. Click on the Bill Of Materials printout and it can be seen that the program now
calculates that 448m of Roofing (20 Sheets @ 4.092m) and (42 Sheets @ 8.711m) are
required. This compares with 452 originally calculated by the program. So although the program
could achieve a quote within 1% of the most efficient quote possible, the manual adjustments
allowed Max to override the program’s sheet optimizer and create a “practical” sheet layout for
use in construction.

Figure 6-2


